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CHAPTER 1
Introduction
Welcome to Video System Manager

Color Kinetics introduces Video With Light™, a new concept for using video-based content to control 
Color Kinetics intelligent solid-state lighting installations. Video With Light is made possible by Video 
System Manager—an integrated hardware/software system comprised of Video System Engine, a 
hardware video processing device, and Video Management Tool, a software mapping tool. Video 
System Manager  allows you to display video-based content onto Color Kinetics Ethernet-based 
lighting installations. Using Video System Manager, each light or light node in the installation acts as 
a pixel in the video display. Therefore, the more densely populated the installation, the better the 
resolution. 

Video Management Tool is a software tool designed specifically for presenting video streams with the 
full line of Color Kinetics lights. Video Management Tool’s graphic user interface lets you easily map 
your lighting installation, set up regions, and create custom fixture and supply templates.

Key Features of Video Management Tool
Video Management Tool is an easy-to-use graphic interface that lets you create a map of your 
installation using drop and drag templates. The most common fixture and supply templates are 
provided for you. However, for custom or unusual configurations, Video Management Tool lets you 
create custom templates to match your installation. Once you have mapped your installation using 
Video Management Tool, you will download the map to the Video System Engine via a webpage.

Video Image Area
The VIDEO IMAGE AREA is located in the main window of Video Management Tool.  This grey area 
defaults to 720 x 480 and represents the canvas size of the video display. It is within this area that 
you create your installation map. 

Editors
From the editors menu located on the menu bar, are the fixture editor, supply editor, interface editor, 
and region editor. These editors allow you to create and define custom templates to reflect unique 
fixture and supply installation.  
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Mapping the Installation
The first step toward playing video on your Color Kinetics lighting system is to create a map of the 
installation. The map sets the sampling parameters for the graphic display. To achieve satisfactory 
graphic presentation, it is necessary that the map exactly match the lighting installation. Video 
Management Tool uses templates to create the maps.

Light templates define how individual nodes of light relate to each other within the fixture. Supply 
templates define how the light templates relate to each other on the power/data (PDS) or Data Enabler 
supply. Supply templates that represent the lighting configuration of your installation are used to build 
a map of the installation.

Video Management Tool provides templates for Color Kinetics’ fixtures and supplies that are most 
commonly used in video installations. If the lighting arrangement for your installation is unique, VMT 
lets you create custom templates. 

Contacting Color Kinetics
Contact Color Kinetics Technical Support if you experience problems with Video Management Tool 
software; phone: 617.423.9999, email: technicalsupport@colorkinetics.com, web: 
www.colorkinetics.com/support.
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CHAPTER 2
Hardware Setup

Video System Manager enables your Color Kinetics Ethernet lighting installation to display video, both 
analog or digital. This chapter describes how to setup your system and configure your computer.

Ethernet Setup
Necessary Hardware
Your Color Kinetics Ethernet lighting system must include an Ethernet switch, a dedicated network, and 
a personal computer with a Pentium processor, or equivalent, with Windows 2000 or XP or Mac OS 
X and an Ethernet card. Additionally, you must have a DV Converter box (Canopus or equivalent) 
configured for your video input. The following block diagram shows a typical configuration.

Dedicated Network
A dedicated network is required for a Color Kinetics Ethernet system. The bandwidth required for the 
Video System Manager is too high for a shared network. Using a shared network for your Video 
System Manager installation can cause poor performance or failure of other network functions.

Cables and Connectors
Always use Category 5e unshielded twisted pair (UTP) cables, or better. Ethernet limits the maximum 
cable run to 328 feet (100m). 

Color Kinetics power/data supplies and Ethernet-ready Data Enablers are fitted with RJ45 data 
connections. Therefore, RJ45 connectors are required for terminating CAT 5e data cables.
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Switches
Video System Engine communicates through Ethernet switches which are used to connect all 
components of a Color Kinetics Ethernet installation and route information between all equipment 
connected to the network. For extremely large installations, a gigabit Ethernet switch can be used to 
increase the bandwidth of the Ethernet network. Refer to Set Up for Interfaces and Lights for a typical 
installation.

Because Ethernet uses a star topology, every component of the network must be connected directly to 
a switch. Therefore, daisy chain connections cannot be made between supplies.

Set Up for Interfaces and Lights
Using CAT 5e data cable with RJ45 connectors connect each supply to a 10/100 Base-T switch. 
When needed, use gigabit switches to increase the size of the network.

Note: Ethernet cannot be daisy-chained. Each PDS or Data Enabler supply must be 
connected directly to an Ethernet switch port.

The following illustration shows a example of a network connection. Depending on the size of your 
installation, your network can be very simple or very complex. Video Management Tool can 
accommodate network trees up to three switches deep between the Video System Engine and the 
farthest interface.
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HARDWARE SETUP

                                                                                                    
Configuring Your PC Ethernet Network
Video System Engine (VSE) is capable of assigning an IP address to your computer automatically. If 
your computer is connected to the VSE, follow the steps below to set the IP address. If you computer is 
not connected to the VSE, for example, when creating pre-installation maps, refer to Manual IP 
Configuration on page 15.

Note: If you have a firewall, or firewall software, on your system, it must be disabled to use 
Video Management Tool software. 

Automatic Configuration for Windows 2000
Follow the instructions below to configure your Windows 2000 OS PC for the network dedicated to 
your Color Kinetics installation. 

1. From the START menu select SETTINGS>CONTROL PANEL. In the CONTROL PANEL double click the NETWORK 
AND DIAL-UP CONNECTIONS folder. From the NETWORK AND DIAL-UP CONNECTIONS window double click 
LOCAL AREA CONNECTIONS. The LOCAL AREA CONNECTION STATUS window appears.

2. In the LOCAL AREA CONNECTION STATUS window click PROPERTIES. The LOCAL AREA CONNECTION PROPERTIES 
window appears.

3. Click to highlight INTERNET PROTOCOL (TCP/IP), then click PROPERTIES. The INTERNET PROTOCOL (TCP/IP) 
PROPERTIES dialog appears.
9
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4. Click the radio buttons to select OBTAIN AN IP ADDRESS AUTOMATICALLY and OBTAIN DNS SERVER ADDRESS 
AUTOMATICALLY.

5. If an IP and DNS address is present, record these numbers for future reference.
6. Click OK to return to the LOCAL AREA CONNECTION PROPERTIES window. From there, click OK to return to 

the LOCAL AREA CONNECTION STATUS window. Click CLOSE to exit.
7. Restart your computer to accept the new network settings.
8. To verify the  configuration, select START>PROGRAMS>ACCESSORIES>COMMAND PROMPT. At the prompt 

enter IPCONFIG and press ENTER. The IP Address will be within the range of 10.1.3.20 to 10.1.3.50. 
The Subnet Mask will be 255.0.0.0. 
10
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Automatic IP Configuration for Windows XP
1. From the START menu select SETTINGS>CONTROL PANEL. In the CONTROL PANEL  click the NETWORK AND 

INTERNET CONNECTIONS.

2. From the NETWORK AND INTERNET CONNECTIONS window  click NETWORK CONNECTIONS.

3. Double click the LOCAL AREA CONNECTION icon. 
11
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4. The LOCAL AREA CONNECTION STATUS window appears. 

5. In the LOCAL AREA CONNECTION STATUS window click PROPERTIES. The LOCAL AREA CONNECTION PROPERTIES 
window appears.

6. Click to highlight INTERNET PROTOCOL (TCP/IP), then click PROPERTIES. The INTERNET PROTOCOL (TCP/IP) 
PROPERTIES dialog appears.
12
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7. Click the radio buttons to select OBTAIN AN IP ADDRESS AUTOMATICALLY and OBTAIN DNS SERVER ADDRESS 
AUTOMATICALLY. Click OK.

8. If an IP and DNS address is present, record these numbers for future reference.
9. To turn off the firewall protection, click the advanced tab from the local area connection 

properties window. Deselect PROTECT MY COMPUTER AND NETWORK BY LIMITING OR PREVENTING ACCESS TO THIS 
COMPUTER FROM THE INTERNET.

10. Click OK to return to the LOCAL AREA CONNECTION STATUS window, then CLOSE.
11. Restart your computer to accept the new network settings.
12. To verify the  configuration, select START>PROGRAMS>ACCESSORIES>COMMAND PROMPT. At the prompt 

enter IPCONFIG and press ENTER. The IP Address will be within the range of 10.1.3.20 to 10.1.3.50. 
The Subnet Mask will be 255.0.0.0 
13
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Automatic IP Configuration for Mac OS X
1. From the APPLE menu select SYSTEM PREFERENCES. The SYSTEM PREFERENCES window appears.  

2. Under INTERNET & NETWORK, click the NETWORK icon. The NETWORK dialog box appears. From the 
LOCATION drop down list, select AUTOMATIC. From the SHOW drop down list, select BUILT-IN ETHERNET. 
Ensure that TCP/IP is selected. 

3. From the CONFIGURE IPV4 drop down list, select USING DHCP. The system automatically obtains IP 
address and subnet mask.

Note: Record the IP, Subnet Mask, and DNS server numbers, if available, in case you need them 
for future use.

4. Click APPLY NOW. Your Mac OS X system is configured.
14
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Manual IP Configuration
If your computer is not connected to the Video System Manager—for example, when you are creating 
pre-installation maps—you must manually configure an IP address.

Windows 2000
1. From the START menu select SETTINGS>CONTROL PANEL. In the CONTROL PANEL double click the NETWORK 

AND DIAL-UP CONNECTIONS folder. From the NETWORK AND DIAL-UP CONNECTIONS window double click 
LOCAL AREA CONNECTIONS. The LOCAL AREA CONNECTION STATUS window appears.

2. In the LOCAL AREA CONNECTION STATUS window click PROPERTIES. The LOCAL AREA CONNECTION PROPERTIES 
window appears.

3. Select INTERNET PROTOCOL (TCP/IP), then click PROPERTIES. The INTERNET PROTOCOL (TCP/IP) PROPERTIES dialog 
appears.
15
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4. Select USE THE FOLLOWING IP ADDRESS. In the IP ADDRESS field enter 10.1.3.20. In the SUBNET MASK field 
enter 255.0.0.0. Click OK.
Note: If an IP and DNS address is present, record these numbers in case you need it for future 
use.

5. To verify the manual configuration, select START>PROGRAMS>ACCESSORIES>COMMAND PROMPT. At the 
prompt enter IPCONFIG and press ENTER.

6. Your IP address is correctly configured if the IP Address and Subnet Mask in the Command Prompt 
window matches what you entered in the INTERNET PROTOCOL (TCP/IP) PROPERTIES dialog box.
16
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Windows XP
1. From the START menu select SETTINGS>CONTROL PANEL. In the CONTROL PANEL  click the NETWORK AND 

INTERNET CONNECTIONS.

2. From the NETWORK AND INTERNET CONNECTIONS window  click NETWORK CONNECTIONS.

3. Double click the LOCAL AREA CONNECTION icon. 
17



CHAPTER 2
4. The LOCAL AREA CONNECTION STATUS window appears. 

5. In the LOCAL AREA CONNECTION STATUS window click PROPERTIES. The LOCAL AREA CONNECTION PROPERTIES 
window appears.
18
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6. Click to highlight INTERNET PROTOCOL (TCP/IP), then click PROPERTIES. The INTERNET PROTOCOL (TCP/IP) 
PROPERTIES dialog appears.

7. Select USE THE FOLLOWING IP ADDRESS. In the IP ADDRESS field enter 10.1.3.20. In the SUBNET MASK field 
enter 255.0.0.0. Click OK.

8. If an IP and DNS address is present, record these numbers in case you need them for future use.
9. To verify the manual configuration, select START>PROGRAMS>ACCESSORIES>COMMAND PROMPT. At the 

prompts enter IPCONFIG and press ENTER.

10. Your IP address is correctly configured if the IP Address and Subnet Mask in the Command Prompt 
window matches what you entered in the INTERNET PROTOCOL (TCP/IP) PROPERTIES dialog box.
19
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Mac OS X
1. From the APPLE menu select SYSTEM PREFERENCES. The SYSTEM PREFERENCES screen appears.

2. Under INTERNET & NETWORK, click the NETWORK icon. The NETWORK screen appears. From the LOCATION 
drop down list, select AUTOMATIC. From the SHOW drop down list, select BUILT-IN ETHERNET. Ensure that 
TCP/IP is selected.  

3. From the CONFIGURE IPV4 drop down, select MANUALLY. In the IP ADDRESS field, enter 10.1.3.20. In the 
SUBNET MASK field, enter 255.0.0.0. Click APPLY NOW.

Note: Record the IP, Subnet Mask numbers, and DNS server number, if available, in case you 
need it for future use.
20
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CHAPTER 3
Installation

Video Management Tool works with the Video System Engine, an Ethernet based video processor. This 
chapter describes how to install Video Management Tool software and upgrade Video System Engine 
firmware.

Before you install the Video Management Tool software, close all running applications, disable virus 
protection, and ensure your computer has enough memory and free disk space.

System Requirements

Windows • PC with Pentium 4, or equivalent, processor with Ethernet card
• Windows 2000, XP
• 128 MB RAM
• 35 MB free disk space

Macintosh • G5 processor
• MacOS X 1.3 or greater
• 128 MB RAM
• 5 MB free disk space
21



CHAPTER 3
Installing Video Management Tool
To install Video Management Tool for Windows 2000
1. Insert the Video Management Tool software CD into the CD ROM drive. Using Windows Explorer, 

navigate to your CD ROM and double click setup.exe to launch the Installer Wizard.
2. The VIDEO MANAGEMENT TOOL SETUP WIZARD appears. Click NEXT.

3. The LICENSE AGREEMENT window appears. Select I AGREE to agree to the terms of the license 
agreement, and then click NEXT to continue the installation.
22
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4. When the SELECT INSTALLATION FOLDER window appears, a default installation folder is selected 
for you. To select another installation folder, click BROWSE.
Select EVERYONE or JUST ME to specify the software user. Then click NEXT to continue.

5. The CONFIRM INSTALLATION screen appears. Click NEXT to start the installation.

6. The INSTALLING VIDEO MANAGEMENT TOOL screen appears during the installation.
23
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7. Once the installation is complete the INSTALLATION COMPLETE screen appears. Click CLOSE to 
exit.

Video Management Tool is now installed on your computer.
Note: The Video System Engine is shipped with the latest version of the Video Management Tool 
firmware. See To Upgrade Video System Engine Firmware From CD on page 31 for updating 
versions.
24



INSTALLATION
To Install Video Management Tool for Windows XP
1. Insert the Video Management Tool software CD into the CD ROM drive. When the D: DRIVE 

window appears (Drive letter may differ.), double click the SETUP.EXE to launch the VIDEO 
MANAGEMENT TOOL WIZARD.  

2. The VIDEO MANAGEMENT TOOL SETUP WIZARD appears. Click NEXT to begin the installation.

3. The License Agreement screen appears. You must click I AGREE and NEXT to proceed.
25
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4. When the SELECT INSTALLATION FOLDER screen appears, a default installation folder is selected 
for you. To select another installation location click BROWSE.

Select EVERYONE or JUST ME to specify the software user. Then click NEXT to continue. 
5. The CONFIRMATION INSTALLATION screen appears. Click NEXT to start the installation.

6. The INSTALLING VIDEO MANAGEMENT TOOL screen appears during the installation. 
26



INSTALLATION
7. Once the installation is complete the installation complete screen appears. Click CLOSE to exit.

Video Management Tool is now installed on your computer. The next step to present video data 
on your Color Kinetics lights is to run Video Management Tool.
Note: The Video System Engine is shipped with the latest version of the Video Management Tool 
firmware. See the section on updating firmware and software for installing later versions.
27
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To install Video Management Tool for Macintosh OS X
1. Insert the Video Management Tool software CD into the CD ROM drive. The drive icon displays 

on the desktop. Double click the icon to expand the folder. 

2. Double click on the VIDEO MANAGEMENT TOOL INSTALLER.PKG icon to start the installation 
process.

3. Click CONTINUE. The Software Licensing Agreement screen appears. 
28



INSTALLATION
4. Before proceeding with the installation, you must click AGREE to indicate you agree to the terms of 
the software license agreement.

5. Then click CONTINUE. Select a destination volume to install the VMT software. Select a folder in 
which the software will reside. 

6. Click CONTINUE. The installation screen appears. Click INSTALL to start the installation.
29



CHAPTER 3
7. When finished, the system prompts to indicate the installation is complete.

8. Click CLOSE to exit the installation program.
After the installation is complete the Video Management Tool application resides in the 
Applications directory on your Macintosh hard drive. You can create a shortcut by dragging the 
Video Management Tool icon to the Dock. 
30
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Installing Upgrade CDs
Occasionally Video System Engine firmware and Video Management Tool software are upgraded to 
provide feature improvements and bug fixes. Color Kinetics makes these upgrades available on CD 
and from the Color Kinetics website.

To Upgrade Video System Engine Firmware From CD
1. With the Video System Engine running, insert the CD into the CD-ROM drive on the Video System 

Engine.
2. Power cycle the Video System Engine.
3. When the Video System Engine reboots, the CD will automatically install. This process will take 

several minutes.
4. Once the installation is complete, the CD will eject.
5. Remove the CD.
6. Power cycle the Video System Engine.

To Upgrade from Downloaded File
To upgrade the Video System Engine firmware from the Color Kinetics website, you must have a 
writable CD-ROM drive with CD creation software.

1. From the Color Kinetics website -- www.colorkinetics.com/support/download/ -- navigate to the 
latest firmware/software upgrade file and click the link.

2. When the file download screen appears, click SAVE to download the ISO file to your computer. 
Select a location on your computer and click SAVE. 

3. After the download is complete, use a CD creation software with a CD writable drive burn the 
ISO file to a CD. Follow the instructions for the CD creation software.
Note: The CD creation software should expand the ISO file into the CD image. The upgrade will 
not work if the ISO file is simply copied onto the CD.

4. Once the CD is created, follow the instructions above—To Upgrade Video System Engine 
Firmware From CD—to update the Video System Engine.

5. If the CD you created is valid, the firmware will install and the CD will eject. If the CD is invalid, 
the Video System Engine will continue running with no interruption.

To Upgrade Video Management Tool software
1. Before upgrading your Video Management Tool software in Windows, you must uninstall the 

current version. To uninstall the current Video Management Tool version, select 
START>SETTINGS>CONTROL PANEL. From the control panel use the ADD/REMOVE PROGRAM tool 
to uninstall the current version. On a Macintosh OS X system, it is not necessary to uninstall the 
current version, but you can uninstall it by simply dragging the application to the trash barrel.

2. After the uninstall is complete, refer to "Installing Video Management Tool" for installation 
instructions.
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Verify Firmware/Software Versions
After upgrading the Video System Engine firmware and the Video Management Tool software, you 
can verify that the software upgrade was successful by matching the current version number to the 
version listed on your CD, or from the web, if downloaded.

To Verify Firmware Version
1. Launch you internet browser and enter http://10.1.3.101. The following screen appears with the 

version of your Video System Engine firmware.
32
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To Verify Software Version
1. Select HELP>ABOUT from the Video Management Tool screen. A list of the current versions of 

software appears.
33
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CHAPTER 4
Quick Start Guide

This section of the Video System Manager User Guide is intended to introduce and explain the basic 
concepts of creating a video display using Video Management Tool, including creating a map, using 
templates, and downloading. 

Mapping the Installation
To display video on your Color Kinetics Ethernet lighting system, you must first create an exact scale 
map of the installation. It is necessary that the map match the installation in order to achieve the 
desired video results. Video Management Tool (VMT) provides templates for Color Kinetics’ fixtures 
and supplies that are most commonly used in video installations. If the lighting arrangement for your 
installation is unique, VMT lets you create custom templates. This Quick Start Guide takes you through 
creating maps using the provided templates.

Understanding Templates and Maps
In order to achieve satisfactory video display, you must create and exact map of your installation. 
Light templates and supply templates are used in creating maps.

Light Templates
Light templates define how individual nodes of light relate to each other within the fixture. Default 
templates for the Color Kinetics fixtures most often used in video displays are provided for you. If your 
installation uses a unique fixture arrangement, you can create a custom light template. For example, if 
your installation uses shortened lengths, less than 50 nodes per string, of iColor Flex, or if your 
installation uses "U" shaped or wrapped strings of iColor Flex, then you define your fixture size and/
or shape by using the FIXTURE EDITOR. 

Supply Templates
Supply templates define how light templates relate to each other on the power/data (PDS) supply or 
the Data Enabler (DE) supply. For example, with typical iColor Flex installations, each PDS supply 
supports two runs of 50 nodes on outputs one and two.  If your installation uses shortened, or unequal 
node lengths on each output, you can create a custom supply template to reflect your installation by 
using the SUPPLY EDITOR. Another example of custom supply template is when your fixtures are 
installed in non-typical runs. For example, if your iColor Module installation is in a staggered, back-
and-forth run instead of typical grid or linear runs.
35
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Maps
The map defines how supply templates relate to each other in the installation. For example, an 
installation grid of 16 iColor Modules, where there are 4 modules per supply requires adding 4 
iColor Module supply templates to the maps. Once the templates are added to the map, drag and 
drop them into position to match the installation. 

Map

Light Templates

Supply Templates
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Video Management Tool Environment
To launch Video Management Tool on your PC, select START>PROGRAMS>COLOR KINETICS>VIDEO 
MANAGEMENT TOOL. From a Mac, click the VIDEO MANAGEMENT TOOL icon located on the dock.

Main Screen

MENU BAR A list of on-screen functions or operations.

STATUS BAR Displays the current area, canvas size and aspect ratio selection.

VIDEO IMAGE AREA A scrollable viewing area that lets you view a virtual representation of 
your installation.
37
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The Menus

The File Menu
The FILE menu commands apply to the map design. From this menu, you 
open and save maps, access background images, and import/export 
templates.

The Edit Menu
The EDIT menu commands apply to the templates within you video 
image area. You can copy and paste, add and delete templates, 
associate supplies, and resize the canvas of the video image.

The View Menu
The VIEW menu commands control the on-screen appearance and 
actions of the map.

The Editors Menu
The EDITORS menu operations access the various editors for defining 
creating fixtures and supply templates, associating interfaces, and 
creating new regions.

The Help Menu
The HELP menu gives you version and build information about Video 
Management Tool
38
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The Information Bar

Current Region
The CURRENT REGION shows you the color of the fixtures in the region that 
you are editing.

Canvas Width and Canvas Height

The CANVAS WIDTH and CANVAS HEIGHT give you the current values of 
width and height. You can edit either value from these fields.

Preserve Aspect Ratio 
The PRESERVE ASPECT RATIO option, when turned on, retains the canvas 
width to canvas height ratio as you build your map.
39
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Creating a Map
Launch Video Management Tool. The NEW MAP window appears. The default  720 X 480 video 
image area is displayed in gray and the CURRENT REGION is set to BASE REGION.

Add Supply Templates
The first step in creating a new map is to add the supply templates. Supply templates represent the 
light fixture(s) and how it is powered and controlled by the supply. For example, one iColor Tile 2x2 is 
powered by one PDS-60ca 7.5V. Output one sends power and data to the nodes on the left side of the 
tile while output two sends power and data to the nodes on the right side of the tile.

Adding a Single Supply Template
1. To add supply templates one at a time, SELECT EDIT>ADD SUPPLY TEMPLATE. The ADD SUPPLY 

TEMPLATE dialog box appears. 

2. From the drop down menu, select ICOLOR TILE FX 2:2. Click OK. The iColor Tile FX 2:2 supply 
template appears on the video image area.
40
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3. Drag the template into position and click to drop.

Adding Multiple Templates
1. To add multiple supply templates at once, select EDIT>ADD MULTIPLE SUPPLY TEMPLATES. The ADD 

MULTIPLE SUPPLY TEMPLATE dialog box appears.

2. Select ICOLOR TILE FX 2:2 from the drop down list. In the NUMBER ACROSS and NUMBER DOWN 
fields, enter the number of fixtures across and down to form a grid. 

3. Ensure that SIZE IMAGE TO FIT and PRESERVE ASPECT RATIO are selected. Click OK.  
41
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The VIDEO IMAGE AREA is populated with a 6 x 4 grid of iColor Tile FX 2:2 supply templates.

Loading Image
For a visual representation of how your video will appear on the installation, you can load an image 
into the VIDEO IMAGE AREA.

To import an image, select FILE>LOAD IMAGE.... Navigate to and select an image, then click OPEN. 
The image is displayed on the VIDEO IMAGE AREA behind the template grid.
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Associate Supplies
Once you have created a map that matches your lighting installation, you must associate each supply 
template in the map to the actual supply or interface in the installation.

Note: Your map must match the actual installation both visually on-screen and physically by 
associating the real-world supply with the mapped supply template.

Maps can be created prior to installation. However, to associate actual supplies to the appropriate 
supply template in the map you must be connected to the installation; therefore, this step must happen 
post-installation.

1. To associate the supplies, select EDITORS>INTERFACE EDITOR. The INTERFACE EDITOR screen 
appears. (A KiNET interface is any Color Kinetics PDS power/data supplies or Data Enabler that 
uses the KiNET Ethernet protocol.) The mapped interfaces are marked with blue squares and are 
labeled FAKE SUPPLY.  To associate the supplies, you must replace the FAKE SUPPLY with the real-
world supply.

2. Click to highlight an actual supply. The interface information appears in the INTERFACE INFO box 
on the right and the lights attached to that supply in the actual installation are highlighted in red.
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3. To replace a FAKE SUPPLY with an actual supply, click and drag the real supply onto the video 
image area. As you drag the supply across the map, each supply template is highlighted. Drop 
the real supply onto the template that represents the actual fixture-to-supply installation.

4. When you drop the real-world supply onto the supply template, one fake supply is removed from 
the list and the associated real-world supply has a blue box preceding it in the list. 

5. Continue associating the real supplies with the mapped supply templates until all fake supplies 
are removed.

6. Close the INTERFACE EDITOR screen.
7. Select FILE>SAVE  to save your map as a .fap (Fast Map) file.
44
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Downloading the Video Map to the Video System Engine
The final step in the process is to download the .fap file and activate your Video System Engine. 

1. Launch your internet browser and enter the address http://10.1.3.101 to access the Video 
System Engine webpage.

2. Click LOAD MAP from the web page. 
3. Click BROWSE and navigate to the map you created. Click OPEN.
4. Click LOAD to download your map. 

Note: Note: If a .fap file currently resides on your Video System Engine, it will be overwritten 
during this process.

5. You will obtain a confirmation screen that your program has been accepted and is running.
6. Plug your video source into the DV Converter box. When properly attached to you Video System 

Engine, your lighting fixtures will present the video data stream.
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CHAPTER 5
Mapping Installations

Video System Manager lets you use your Color Kinetics Ethernet lighting installation as a video 
display, where each light, or light node, acts as an individual pixel. The first step to streaming video 
onto your lighting installation is to create an exact map of the installation. It is necessary that the map 
match the actual installation, including multiple regions, in order to achieve satisfactory video results.

Note: Video System Manager does not "discover" or address lights in your installation. You 
must address your lights prior to installation and map your installation using defined supply 
templates.

While you are working through this chapter, it will be useful if you understand the following terms:

• Map - the map you create defines how supply templates relate to each other in an installation.
• Supply Template - defines how light templates relate to each other on the supply.
• Light Template - the light template defines how each light node relates to others in a fixture.

For example, an installation grid of 16 iColor Modules, where there are 4 modules per supply 
requires adding 4 iColor Module supply templates to the maps.  

Map

Light Templates

Supply Templates
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Creating Maps
Launch Video Management Tool by selecting START>PROGRAMS>COLOR KINETICS>VIDEO 
MANAGEMENT TOOL from a PC or by clicking the VIDEO MANAGEMENT TOOL icon on the dock from a 
Mac. 

A grey VIDEO IMAGE AREA is displayed. The default canvas size is 720 wide by 480 high and the 
PRESERVE ASPECT RATIO is selected. As you create your map, the canvas size will change to assure a 
video-to-display best fit. PRESERVE ASPECT RATIO must be selected to ensure that the video does not 
appear stretched or distorted on the installation.
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Add a Supply Template
Video Management Tool provides supply templates for Color Kinetics’ most commonly used video 
display fixtures. If you are using modified fixtures, such as shortened or "U" shape installed strings of 
iColor Flex, you can create a custom template to match your installation. Refer to Creating Custom 
Templates on page 53 for instructions for creating fixture templates.

Add a Single Supply Template
1. If your installation uses any combination of the standard video display fixtures, select EDIT>ADD 

TEMPLATE to add supply templates one at a time. 

2. From the drop down menu, select the template from the drop down list.
Click OK. The supply template you selected appears in the gray VIDEO IMAGE AREA in the main 
window. Drag the template to best match the actual placement in the installation and click to 
drop. 
Note: The default condition for the template positioning is "snap to grid". To change this, select 
VIEW>SNAP TO GRID.

3. Position the template to best match the actual placement in the installation. Click to drop the 
template. At any time you can click to highlight a template, then drag and drop it to a new 
position in the VIDEO IMAGE AREA.

If the orientation of the template is incorrect (e.g., vertical Flex when you need horizontal Flex), 
right click on the template to select ROTATE SELECTION CW or ROTATE SELECTION CCW.
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4. After adding all supply templates to complete the map of your installation, ensure that PRESERVE 
ASPECT RATIO is selected, then select EDIT>AUTO-RESIZE canvas. The video image area is resized 
proportionally to best fit your installation. Notice the new canvas size on the status bar.

Only the video image area within the grid is displayed on your lighting installation. For a visual 
representation of how the video will appear on your installation, insert an image by selecting 
FILE>LOAD IMAGE.... To remove the image, select FILE>REMOVE IMAGE.

5. Once you have mapped the lights in you installation, select FILE>SAVE to create a .fap (Fast Map) 
file. This saved file will be downloaded to the Video System Engine.
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Add Multiple Supply Templates
1. If your installation is made up of a grid of multiple identical templates, select EDIT>ADD MULTIPLE 

TEMPLATES. The ADD MULTIPLE SUPPLY TEMPLATES dialog box appears.

2. Select the appropriate template from the drop down menu. Enter the NUMBER ACROSS and the 
NUMBER DOWN. Ensure that SIZE IMAGE TO FIT and PRESERVE ASPECT RATIO are selected. 
Selecting these options prevents the video from appearing distorted. Click OK. The fixture 
template you selected appears in a tiled grid in the gray VIDEO IMAGE AREA in the main window.

3. If the templates need to be moved to match the actual installation, select and drag the templates 
to a new location and click to drop them in place. At any time you can click to select a template 
or multiple templates, then drag and drop to a new position in the VIDEO IMAGE AREA.
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4. Once you have mapped the lights in your installation, select FILE>SAVE to create a .fap (Fast 
Map) file. This saved file will be later downloaded to the Video System Engine.

Add a Combination of Fixtures
1. Use the ADD SUPPLY TEMPLATE or ADD MULTIPLE SUPPLY TEMPLATES dialog box to add and 

position single or multiple templates to match the exact configuration of your installation. 
Note: If you have added individual supply templates to complete the map of your installation or 
you have a combination of more than one type of supply template, ensure that PRESERVE ASPECT 
RATIO is selected, then select EDIT>AUTO-RESIZE CANVAS. The video image area is resized 
proportionally to best fit the installation. Notice the new canvas size on the status bar.

2. Once you have mapped the lights in your installation, select FILE>SAVE to create a .fap (Fast 
Map) file. This saved file will be downloaded to the Video System Engine.

Now that you have created an exact map of your lighting installation, you are ready to associate the 
power/data supplies in your installation to the lights they control. See Associating Templates to 
Supplies on page 63.  
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Creating Custom Templates
If your installation includes custom fixtures such as shortened lengths of iColor Flex or "U" shaped 
installations of Flex, then you must create custom templates. You must first create a new fixture template 
to define your fixture. Next you will create a supply template to define the fixture-to-supply 
configuration. In this section, you will create a custom template for a non-standard Flex configuration.

Creating a Fixture Template
1. From the menu, bar select EDITORS>FIXTURE TEMPLATE EDITOR.

The FIXTURE TEMPLATE EDITOR screen appears. You will see the default fixture templates provided with 
Video Management Tool. Click on each one in the left screen to see their configurations in the right 
screen. If you place the cursor over a box in the fixture, it will indicate the number of that light node in 
the fixture. 

Note: Each of the provided fixture templates has a padlock icon in front of it, indicating that 
it cannot be changed. You can, however, CLONE the locked template and RENAME the cloned 
template to create an editable template.
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2. Highlight the iColor Flex SL fixture and click CLONE. This creates a copy of a 50 light string. 
Immediately RENAME this to some name descriptive of your installation. In this case, we are 
creating a "U" shaped fixture.

3. Click and drag the lights until they match your installation. You can add a background grid, a 
fixture boundary, or lines indicating the node ordering to aid in your positioning of lights.
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4. Alternately, you can create a custom fixture template by selecting NEW.  A linear run of 50 light 
nodes appears in the layout window. You can adjust the number of light nodes using the NUMBER 
OF NODES field above the layout window. Click and drag the nodes to a new configuration. Click 
RENAME to a assign a new name to the fixture template. For example, you may have reduced the 
length of your iColor Flex SL strings to 24 nodes as shown here.

5. Verify the configuration of the lights by passing the cursor over each and noting the number 
sequence. Node number 1 is highlighted in red and the last node is highlighted in blue.
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Testing Fixture Addresses
When creating post-installation fixture templates, you can test the physical addressing of installed 
fixtures to ensure that the template and the actual fixture match.

1. With FIXTURE TEMPLATE EDITOR window open, select EDITOR>INTERFACE EDITOR from the VIDEO 
MANAGEMENT TOOL window.

2. From the interface editor window, select a supply that corresponds to the fixture template you 
created. Drag the selected supply to the FIXTURE TEMPLATE EDITOR window and drop in into the 
layout panel. 
The selected supply appears in the ASSOCIATED WITH field. Now that you have associated a 
supply to the new fixture template, as you click each node in the template, the corresponding 
node on your actual light turns red.

3.  Close the FIXTURE TEMPLATE EDITOR screen when you are done. All new fixture templates are 
automatically saved. Close the INTERFACE EDITOR.
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Understanding the Supply Template Editor
The SUPPLY TEMPLATE EDITOR lets you create a template which matches how your supplies are 
configured in your installation.

1. Select EDITORS>SUPPLY TEMPLATE EDITOR.

The screen has three sections. On the left is the list of the currently defined supply templates. In the 
center layout window is the graphical representation of the fixtures in the highlighted template. At 
the bottom of the screen is the list of supply outputs and the associated fixtures for the template. 
All of the standard supply templates are preconfigured to typical Color Kinetics supplies. The first 
column indicates the outputs by number. The row next to the output number contains the fixtures 
powered by that output.
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2. Click NEW. A NEW TEMPLATE is added to the template list. 
3. Highlight NEW TEMPLATE and click RENAME. Enter a name to describe your template.

4. Click ADD OUTPUT once to create a second output for a single PDS-60ca 7.5V.

Note: Each time you click Add Output, a new output number is added to the first column. Each 
time you click Add Fixture, a new fixture is added to the row of the selected output.
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Creating a Supply Template
You are now going to create a custom supply template using the fixture template you created.

1. From the SUPPLY TEMPLATE EDITOR, click ADD OUTPUT to add output 2.
2. From the output 1 row and fixture column 1, select the template you created from the drop down 

menu - in this case "U shaped fixture". Repeat for the second output.

Each time you select a fixture template from the output list, an image of it is placed on the layout 
window.
Note: In the layout panel, each time an output is added to the template, the fixture location for 
the output appears in the same location. Therefore, each time you add a fixture to an new output, 
it is necessary to click and drag the fixture to a new location to prevent it from being hidden by 
other fixtures.

3. Drag and drop the fixtures into the positions that best matches your installation.
4. Close the window. All your changes are automatically saved.

You new supply template is complete. To create a map using this new template, proceed from 
Add a Supply Template on page 49.
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Regions
A single video stream can be sent to one region of your light system or to all regions. The previous 
chapters have detailed the procedure for creating an individual map of lights for the video stream. If 
you have another system of lights that you want to use to see the same video stream or a portion of it, 
you can create a new region in Video Management Tool and follow the same setup procedure for the 
new region.

Creating a New Region for Video Management Tool
1. Select EDITORS>REGIONS editor.

2. Select NEW to create a new region.
3. Name the new region and select a color for this region.

4. Close the screen to complete the region definition.
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5. On the main Video Management Tool screen, scroll the CURRENT REGION drop down menu to the 
new region. Proceed through the Fixture, Template, and Source Editors, as necessary. Add the 
templates onto the video image area and save the results into the .fap file. When you go to 
identify the power supplies for the templates, the color marker in front of the Fake Supplies is now 
the color of the CURRENT REGION. In the following image, we have created supply templates of 
2X5 sets of 3-by--3 modules, and added 2 across and 2 down multiple templates.
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CHAPTER 6
Associating Templates to Supplies

Now that you have mapped the supply templates, you must associate each supply template to a real-
world template in your installation.

Note: Before you begin, ensure that your computer is connected to the Color Kinetics 
dedicated network.

Video Management Tool has created a series of Fake Supplies for each supply templates that you  
placed on the video image area. You must associate each of these Fake Supplies with its actual supply 
in your installation.

1. Select EDITORS>INTERFACE EDITOR. The INTERFACE EDITOR screen appears. The set of Fake 
Supplies are highlighted by blue boxes. Each of these must be associated to a real supply for the 
video image to display properly.

2. Highlight a FAKE SUPPLY. Its corresponding template on the image screen is highlighted in red. 
Associate the correct interface from the list of supplies by selecting the actual supply (e.g., TILE 
WALL LOWER LEFT), dragging, and dropping it onto the appropriate template on the image 
screen. The image below shows the FAKE SUPPLY for the lower left corner of the image.
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When you complete this process, the applied interface is highlighted by a blue square, and one FAKE 
SUPPLY is removed from the list. The main Video Management Tool screen also highlights the specified 
template in red. 

3. Continue to associate the all other supply templates with their actual supplies until all Fake 
Supplies have been associated to real supplies.

4. Close the INTERFACE EDITOR screen.
5. Select FILE>SAVE into a .fap (Fast Map) file.
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Smart Association of Templates to Supplies
Video Management Tool can associate supply templates to actual supplies in your installation 
automatically. This procedure will bypass the manual association of Fake Supplies. Your installation of 
supplies and fixture templates are associated according to specifications defined by you.

Note: For SMART ASSOCIATE to work well, you should pre-address your supplies and lay 
them out in an ordered pattern. An ordered layout is necessary for a successful smart 
associate since the order options in the SMART ASSOCIATE dialog are limited to row, column, 
and order coordinates.

1. Open the SMART ASSOCIATE dialog box by selecting EDIT>SMART ASSOCIATE. 

2. In the ORDER box, enter the DIRECTION, ROW ORDER and COLUMN ORDER to match your 
installation.

3. In the TEMPLATE box, define the supply templates to associate.
4. In the SUPPLIES box, select all supplies or define a start and end supply range.
5. Click OK. The supplies in your installation are automatically associated with the templates in your 

map. 
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6. Open EDITORS>INTERFACE and note that the list of interfaces contains no Fake Supplies. Each 
supply is associated with one template in the video image screen. 

7. Verify that all templates are associated properly to their respective power supplies by clicking on 
the templates in the map. Each selected template will cause the corresponding lights in the 
installation to turn red. 

Note: Make any necessary corrections by running SMART ASSOCIATE again and modifying the 
direction and order, ensuring that the SKIP ASSOCIATED TEMPLATES option is not selected, or by 
manually dragging and dropping the supplies from the INTERFACE EDITOR onto their proper 
templates in the map. 

8. Close the INTERFACE EDITOR screen to complete the association.
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CHAPTER 7
Download and Video Input

Now that you have mapped your lights, associated the supplies to the templates, and confirmed the 
positioning of your video image, the final steps are to download the .fap file and activate your Video 
System Engine.

1. Launch you internet browser and enter the address http://10.1.3.101. The Video System 
Manager webpage appears. 

Note: If a .fap file is resident on your Video System Engine, it will be overwritten during the 
download process. You may want to back it up before loading a new map. See Backup on page 
70.
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2. From the webpage, click LOAD MAP. You have the option of upload the map file you created from 
your computer hard drive, a CD drive, or a USB drive. The map file must have a .fap extension 
for it to be recongnized on a CD, USB, or hard drive. From your hard drive, click BROWSE  to 
locate the file, then click LOAD. From the CD or USB drive, select the radial button next to the file, 
then click LOAD.
Note: If a .fap file is resident on your Video System Engine, it will be overwritten during this 
process.

3. You will obtain a confirmation screen that your map has been accepted and is running.
4. Plug your video stream into the DV Converter box. When properly attached to your Video System 

Engine, your lighting fixtures will present the video stream.
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Other Functions Accessible from the Download Web Page

Set Region
You have a choice of activating a single region only or the entire set of regions. The SET REGION 
option lets you select the single region. 

Load Gamma
The Gamma file is a text file that relates the full-range intensity scale (0 to 255) to any range or order 
of colors you choose. Data is placed in column A for rows 1 through 256, and the intensity scale you 
set is for all three RGB lights. For example, if you wanted reverse color, you would put the numbers 
255 through 0 in a column on rows 1 through 256. In some light systems, flicker occurs when you are 
expecting black. By mapping the first twenty or so rows to zero and then scaling the remaining 236 
levels appropriately, you may be able to avoid this. Locate the appropriate gamma file by browsing 
and load it. The gamma file must have a .gam extension to be discovered in USB/CD volumes.

To upload the gamma file from your hard drive, click BROWSE to locate the file, then click LOAD. To 
upload from a CD or USB drive, select the radio botton next to the file and click LOAD.

Note: You can remove the current active gamma file by clicking DELETE.
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Log File and Map Info
Clicking on these two options provides you with information on the status of the program and a 
detailed listing of the map. These are typically only used as diagnostic tools if your system is not 
working as you expect.

Backup
When you download a map file to your Video System Engine, it automatically deletes any existing 
map on the system. Before doing this, if you want to save the current map, do a backup first. Click 
BACKUP and choose whether you want to back up the map or the gamma file. Browse to the folder 
and name the file for saving the current configuration.
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APPENDIX A
Glossary

10.1.3.101  - Go to this website location for downloading your video map to the Video System 
Engine.

Add Fixture/Delete Fixture  - Adds or removes fixtures from outputs of supply templates.

Add Supply Templates/ Add Multiple Supply Templates  - Place standard or preconfigured 
templates onto the video image area.

Associating Supplies to Supply Templates  - Create the software connections on your map that
specify which template is physically attached to which supply.

Backup - Before installing your map file onto the Video System Engine, thereby deleting the current 
file, backup the existing video map. You can also backup the Gamma file.

Base Region  - Select the default region of lights that you are illuminating with your video
image.

Canvas Width/Height  - The horizontal and vertical dimensions of the video image area in pixels.

Current Region  - If you have multiple regions of lights that are all using the same video stream, the 
Current Region shows you which region you are editing.

Downloading  - Take the developed map information and download it to the Video System Engine.

DV Converter Box  - The Digital Video Converter box takes the input from the video stream source 
and sends it through the Firewire to the Video System Engine.

Edit Menu Commands

Copy/Paste  - Standard copy and paste functions for reproducing templates on the image 
screen.
Select All  - Select all templates in the video image area.
Delete Selection  - Delete the selected templates from the screen.
Smart Associate  - Searches the network for probable matches of your map configuration to 
real fixture templates.
Auto-resize canvas  - Automatically rescales the image screen canvas to best fit your current 
set of templates.
Add Supply Template/Add Multiple Supply Templates  - Add a single template or 
multiple templates to the video image canvas.
Preferences  - Select colors for various parts of the templates and screen.
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Editors Menu Options

Fixture Template Editor  - Opens the Fixture Editor screen where you can create and edit 
fixtures to match your actual lighting system.
Supply Template Editor  - Assigns power supplies to the fixture templates that are currently in 
the video image area.
Interface Editor  - Associates specific physical power supplies to match the Fake Supplies 
defined in Supply Template Editor.
Regions Editor - Create or delete additional regions of lights that will be using the same video 
input signal and the same Video System Engine.
Always on Top  - Toggles between two modes: (on) all open editor screens appear on top of the 
main screen and must be closed before returning to the main screen, (off) each editor screen is 
opened as a new window and each window, including the main screen, can be accessed 
independently.

Fake Supply  - A temporary supply type that you associate with the templates in your image area. 
These are replaced by physical power supplies by the Interface Editor.

File Menu Commands

New/Open  - Standard new and open functions for starting or continuing with a video map.
Load Image/Remove Image  - Load and remove a still image in the video image area. This 
may benefit you in determining pixel resolution and fill of your lights.
Save /Save As  - Standard save and save as functions for saving the current configuration of 
your map.
Import Template /Export Template  - Import or export a template format that you have 
created.
Exit  - Close Video Management Tool.

Firewire  - The Color Kinetics required connection between the DV Converter box and the Video 
System Engine.

Fixture Setup/Design  - The Fixture Template Editor screen allows you to create and edit fixtures 
that match your actual installation.

Gamma File/Loading  - Select a text file that matches the standard intensity values,
0 to 255, to a user-defined set of intensities.

Help Menu Option

About Video Management Tool  - Standard access to standard information on the software 
and hardware.

Horizontal String   - A string of fifty lights strung horizontally.

Interface  - A data supply associated with a fixture template - either a power supply or a data 
enabler.

Interface Editor  - Assigns specific physical power supplies to match the Fake Supplies defined in 
Supply Editor.
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KiNET Interfaces  - A Color Kinetics Power/Data supply that uses Color Kinetics Ethernet protocol. 

Load Map - Loads the video map you just created into the Video System Engine.

Log File  - A list of information on your map and its ability to run your lights. Applications support at 
Color Kinetics will typically ask for a copy of the file to evaluate any problems you are 
having.

Map Info  - A list of information on your map. Applications support at Color Kinetics will typically ask 
for a copy of the file to evaluate any problems you are having.

Output/Add Output/Remove Output  - Create and edit or remove the connections from power 
supplies (Fake Supplies) to templates.

Preserve Aspect Ratio  - Use to hold correct scaling as image size is changed.

Region Setting  - Create, edit and delete regions in the same video image area.

Regions  - Multiple areas of you lighting system where you may want to present part or all of the 
same video images data simultaneously.

Size Image to Fit  - Scales the image size to best fit the installation.

Supply Templates  - Sets the supply outputs and fixtures that fit within one template.

Templates  - A structure of fixtures that are associated with an output from an individual supply.

Template Setup/Controller  - Establishes the structure of a template, based on the individual 
fixtures, and associates a supply format to the fixtures.

Video Playback Device  - Source of the video stream, either a direct feed or DVD stored video, 
which is fed to the Digital Video Converter.

Video System Engine  - Processes the video stream from the Digital Video Converter, using he map 
and gamma files, and sends the reformatted data to the power supplies.

View Menu Commands

Zoom In/Zoom Out - Standard zoom in/zoom out functions.
Snap to Grid  - Toggles between forcing and not forcing templates to snap onto the background 
grid structure.
Show Grid  - Shows or hides the grid structure on the video image.
Change Grid  - Change the dimension of the grid spacing.
Display Item Structure  - Show or hide the individual lights within each fixture/template.
Sample Background - Show or hide the pixel resolution of the background image.

VMT  - Video Management Tool.

Zoom In/Zoom Out  - Standard zoom in/zoom out functions.
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