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Chapter 1

Introduction

 Condé Nast Cafeteria
 New York, NY

Welcome to Video Management Tool
Video System Manager Pro is an integrated hardware and software solution designed for video 
playback and visual effects display on Ethernet-based LED lighting installations.

• Video System Engine Pro (VSE Pro), the hardware component, processes and streams live 
video to installations comprising up to 250,000 LED nodes. Refer to the Video System 
Manager Pro User Guide for detailed instructions on configuring and using the hardware.

• Video Management Tool (VMT) software, included with VSE Pro, creates video maps that 
associate source video pixels with their destination nodes in a lighting system. This document 
describes how to create and edit video maps using VMT.

Key Features
VMT features include the following: 

• Flexible, node-level mapping and individual node masking 

• Automatic node distribution

• Merging of multiple maps

• Background image display

• Full backwards compatibility with legacy VSE hardware and VMT version 1.0 maps
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About VMT and DMX Addressing
Every node in a lighting fixture is assigned a DMX address that VMT calculates and includes in 
the video map. When calculating DMX addresses, VMT assumes that each fixture’s nodes are 
addressed sequentially starting at 1, and increments three channels per node (one channel each 
for red, green, and blue channels). 

DMX addresses cannot be changed using VMT. It is important for the installer to understand this 
and set up fixtures and power supplies accordingly when configuring the lighting system. 

Related Documents
The following PDF documents are available for download via the web from 
 www.colorkinetics.com/ls/controllers/vsmpro/.

• VSM Pro Product Guide

• VSM Pro Specification Sheet 

• VSM Pro Installation Instructions

• VSM Pro Quick Start Guide 

• VSM Pro User Guide 

You will need Adobe® Reader to view the documentation. You can download the latest version  
of Acrobat Reader at www.adobe.com.

 Technical Support Contacts
Contact Philips Color Kinetics technical support if you have any questions about our products:

Phone
888.Full.RGB, press option number 3 (toll free US, Canada and Mexico)
617.423.9999, press option number 3 (toll worldwide)

Email
technicalsupport@colorkinetics.com

Web
www.colorkinetics.com/support/
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Chapter 2

VMT Concepts

Overview
• When set up for video display, LED nodes (clusters of red, green, and blue LEDs) function as 

video pixels.

• A video map created in VMT accurately links each node to a pixel in the source video. 

• VSM Pro hardware uses the video map to send video output to each node in an installation.

• You transfer the video map file from VMT on a personal computer (PC or Mac) to VSE Pro.

• The personal computer must be set up on the same dedicated lighting network as VSE Pro.

Creating Video Maps
In VMT, you create a video map by placing lighting fixtures on a grid representing the source 
video, and then associate the fixtures with their power supplies. 

There are two methods for creating a video map: placeholder and interactive:

• Virtual mapping enables you to create a map off-site, prior to installation, without actually 
connecting to any lighting system components. First, based on the lighting design plan, you 
create a list of placeholder power supplies and their IP addresses in VMT. Next, using the 
tools in VMT, you create and properly orient fixtures on a grid. Finally, you associate fixtures 
with their placeholder power supplies.   
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• Interactive mapping enables you create your map during installation based on real-world 
power supplies. First, you connect VMT to the lighting network — VMT will automatically 
discover all power supplies. Next you create fixtures on a grid. Finally, you associate fixtures 
with their power supplies.

Transferring Video Maps
When the map is complete, you transfer the map to the VSE Pro. You can either connect to the 
VSE Pro and upload the map file, or save the file for later use. Note that the computer hosting 
VMT must be set up on the same dedicated lighting network as VSE Pro. See the Video System 
Manager Pro User Guide for additional details.

Troubleshooting
Once the map is transferred to VSE Pro, you can use test patterns and video optimization 
features to test and troubleshoot your map. See the Video System Manager Pro User Guide 
for details.
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Chapter 3

Setup

System Requirements
VMT is compatible with Windows® PC and Mac OS X personal computers:

Windows® Mac OS X
Windows® XP / Vista Mac OS X 10.4.9 or greater

256 MB RAM 256 MB RAM

40 MB free disk space 40 MB free disk space

CD-ROM or DVD drive CD-ROM or DVD drive

Software Installation

Before You Begin 
VMT software comes factory loaded on the VSE Pro. To copy the software to your computer, 
first connect it to the lighting system network (or directly to a VSE Pro Ethernet port) as 
described under on the next page.

The latest version of VMT software is also available for download via the web at: 
http://www.colorkinetics.com/ls/controllers/vsmpro/. 

Before you install VMT, close all running applications, disable virus protection, and ensure your 
computer has enough memory and free disk space.

Windows® Installation
To install the VMT software:

1. Use a web browser to open the VSE Pro interface at IP address 10.1.3.101.

2. Click Video Management Tool v2.0 Windows Installer.

3. The Video Management Tool v2.0 Setup Wizard window appears. Click Next to begin 
the installation. 
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4. After reading the license agreement, select I Agree to consent to the terms of the license 
agreement, then click Next to continue.

5. When the Select Installation Folder window appears, accept the default location, or click 
Browse to select a folder. Click Next to continue.

6. At the Confirm Selection window, click Next to start installation.

7. The Installation Complete window appears. Click Close to exit the wizard.

Mac OS X Installation
1. Use a web browser to open the VSE Pro interface at IP address 10.1.3.101.

2. Click the Video Management Tool v2.0 Mac OS X Installer link.

3. If your browser does not automatically mount the disk image, double-click the downloaded 
file to open (mount) it. This creates a mounted disk image icon on the desktop and opens a 
disk-image folder window containing the VMT application icon. 

4. Drag the VMT application icon to a Hard Disk location such as the Applications folder. Close 
the disk-image folder window. 

Note: Be sure to drag the VMT application out of the opened disk image window and onto 
your Hard Disk before running it. Do not double click the VMT icon in the disk image.

5. Select the mounted disk image by clicking it once.

6. From the File menu, select Eject VMT. Alternately, you can control-click the mounted disk 
image icon and choose Eject.

7. Drag the .dmg file to the trash (unless you want to keep it as a backup).

Network Connection
The VSM Pro lighting network is a dedicated LAN (local area network). The computer hosting 
VMT connects to any switch on the dedicated network using CAT-5e cable. 

No configuration is required in most cases. If the VMT computer’s network interface is set to 
obtain an IP address automatically (using DHCP), it will be configured by the VSE Pro when it 
connects to the dedicated lighting network. 

Note that firewalls may need to be disabled to allow the connection. Please consult your 
network administrator about firewall issues.    

If you experience difficulty establishing a network connection, refer to Network Options on 
page 10, and Manual Network Configuration on page 45. 

For more information about the lighting system networks, refer to the Video System Manager Pro 
User Guide.

Note: Philips recommends that you consult a third-party network consultant regarding 
specifics of your network components and configurations.
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User Preferences

Network Options

If VMT fails to connect to the lighting system network, the problem may be that the computer 
has multiple network interfaces, for example Ethernet and wireless, and VMT is not using the 
right one. This can be solved by changing your network preference setting. 

The Preferences dialog lists network options by IP address, followed by subnet mask. The IP 
address associated with the lighting network starts with 10.1.3.X. 

If no IP address in the list starts with 10.1.3.X, you may need to configure your network 
interface manually. See Manual Network Configuration on page 45.   

To select your network preference:

1. Select Preferences from the Edit menu. 

2. Click the Network tab. 

3. Select the network interface with an IP address starting with 10.1.3.X 

4. Click Use selected. 

5. Click OK.
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Update Options

VMT software may be updated periodically. You can configure the application to automatically 
check for updates by enabling the Automatically check for updates option on the Updates 
tab. If a more recent version is available, you will be prompted to download it. 

You can manually check for updates at any time by clicking Check Now. 

These features require an Internet connection; they may not be available when you connect the 
computer to a dedicated lighting network. 

Color Options

In the Colors tab of the Preferences dialog, you can change the colors displayed by lighting 
fixtures when their power supply or port is selected. 

To change a display color: 

1. Select Preferences from the Edit menu. 

2. Click the Colors tab on the Preferences dialog.

3. Click a color field and select a color in the Select color dialog. 

4. Click OK. 
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Chapter 4

The VMT Interface

Identifying Areas of the Screen 

Windows® PC Screen    

1. Title Bar

2. Menu Bar

3. Toolbar

4. Map Window

5. Power Supply List

6. Port Selection Buttons

7. Status Line
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Mac Screen

1. Title Bar

2. Menu Bar

3. Toolbar

4. Map Window

5. Power Supply List

6. Port Selection Buttons

7. Status Line

Title Bar
The title bar displays the zoom level and the name of the current map file. 

Unsaved changes are indicated in the PC interface by an asterisk after the file name; in the Mac 
interface they are indicated by a dot in the center of the red close button. 

Menu Bar
The menu bar organizes the software’s commands into functional categories and allows you to 
select commands and options with the mouse. Keyboard shortcuts, when available, are shown 
to the right of each command. In the PC interface, you can open menus from the keyboard by 
pressing the [Alt] key plus the letter underlined in the menu label. 

Menu commands are described in the next chapter.  

Toolbar
The toolbar provides easy access to the frequently-used commands in the Tool menu. These 
are described under Tool Menu on page 21. The toolbar can be hidden via the View menu. 

2
1

3

54

6

7
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Map Window
The map window contains a 1024 x 768 grid on which you place virtual fixtures. The grid cells 
represent pixels in the video image. 

Use the Zoom Out / Zoom In tools to view more or less of the grid. Use the scroll bars and 
the Pan tool to view a different section of the grid. Note that the grid lines are not shown at low 
zoom levels and there is an option to hide the grid lines in the View menu. 

You can place bounding boxes that represent the video frame of common video formats on the 
grid by selecting Resolution Guides from the View menu.

Background Image
For visual reference, you can add a background image to the map. VMT provides several test 
patterns and you can load your own graphic file; the .jpg, .jpeg, .png, .tif, and .tiff formats are 
supported. 

To display a background image in the map window:

1. Select Background Images from the File menu. 

2. Click one of the test patterns in the submenu or click Select File to load your own image. 

3. You are  prompted to select whether to scale, center, or tile the image. 

–If you want the image to fill the map grid, select Scale to fit map or Repeat as tiles 
to fill entire map. 

–If you want the image to fill the area covered by virtual fixtures, select Scale to fit 
current fixture layout. 

–If you do not want to scale the image, select Center on map.  

4. Click OK.

Virtual Fixtures

Every fixture in the LED lighting system must be represented on the map by a virtual fixture with 
the same node dimensions. A virtual fixture consists of circles bounded by a box, as shown 
above. 

• The circles represent individual nodes. 

• Red indicates masked nodes, that is, nodes displaying black output. 
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Other colors indicate fixture status, as shown below. Note: an associated fixture is one that has 
been linked on the map to a power supply port.    

The numbers inside the circles designate node order. Node order can be easily changed. The 
number at the top left corner is the port number of the associated power supply. 

The View menu contains options for hiding bounding boxes, node numbers, and port numbers. 

Power Supply List

The power supply list displays both supplies detected in the lighting network and supplies 
associated with fixtures on the map. It can be closed or floated to maximize the map window. 
To display the power supply list, select Show Power Supplies from the View menu.

You can sort the power supply list by name and IP address by clicking the column labels. You can 
also filter the list to show power supplies with a particular status or power supplies within a 
designated IP address range by selecting a filter from the drop-down list. 
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Port Selection Buttons 

The numbered port buttons activate any fixtures connected to the corresponding ports on the 
selected power supply. See Determining Port Connections on page 36. 

Status Bar

From left to right, the status bar displays the following information:

• Position of the top-left node of the selected object(s)

• Horizontal and vertical size of the selected object(s)

• Number of groups selected

• Number of fixtures selected

• Number of nodes selected

• Associated power supply for the selected fixtures 

• Total number of nodes on the map
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Chapter 5

Menu Commands

VMT Menu (Mac only) 

Select... To... 

About VMT Display software version information.

Preferences... Modify user settings and check for software updates. 

Services Open a utility. 

Hide VMT Minimize the VMT window. 

Hide Others Minimize all other windows.

Show All Show open applications.  

Quit VMT Close the application.
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File Menu (Mac and Windows)

Select... To... 

New Map Start a new map.

Open Map... Open an existing map.

Append Map... Add the contents of a saved map to the current map. 

Background Images Select a background image to display in the map window.  

Save Map Save the map with the current file name.

Save Map As... Save the map with a different file name.  

Export Map to CSV... Generate a comma-separated values file with map data.

(A numbered file name) Load a specific map.

Exit (PC only)  Close the application.
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Edit Menu (Mac and Windows)

Select... To...

Undo Cancel previous operation.

Redo Restore an operation cancelled with Undo. 

Cut Remove the selection and copy it to the clipboard.

Copy Copy the selection to the clipboard.

Paste Insert clipboard content on map. 

Delete Delete the selected object(s).

Duplicate Make a copy of the selection. 

Select All Select all objects on the map.

Deselect All Deselect all objects on the map. 

Select Next Node Select the next node.  

Select Previous Node Select the previous node. 

Group Bind selected fixtures together in a group.  

Ungroup Break a group into its component fixtures.

Move to Front Bring the selected object to the top of the stack.

Move to Back Send the selected object to the bottom of the stack.

Transform Rotate and / or flip the selected fixture. 

Distribute Nodes... Space selected nodes evenly over a designated rectangle. 

Mask Selected Nodes Disable selected nodes. 

Unmask Selected Nodes Enable masked nodes. 

Lock Selected Fixtures Prevent selected fixtures from moving. 

Unlock Selected Fixtures Allow selected fixtures to move.

Preferences... (PC only) Modify user settings and check for software updates. 
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Tool Menu (Mac and Windows)

Fixture Menu (Mac and Windows)

Select... To...

Associate Link virtual fixtures to a port on the selected power supply. 

Select Select objects on the map.  

Move Select and move objects on the map.

Clone Add copies of a fixture or group. See Cloning Fixtures on page 26. 

Zoom In Display a smaller section of the map. 

Zoom Out Display a larger section of the map. 

Pan View a different section of the map. 

Add Nodes Add nodes to a fixture. 

Del. Nodes Delete nodes from a fixture.  

Sel. Nodes Select individual nodes.

Move Nodes Move individual nodes.

Select... To...

New Fixture... Create a new fixture and add it to the map.

Add Fixture Add a fixture from the library to the map. 

Save to Library... Save the selected fixture(s) to the fixture library. 

Replace with Replace the selected fixture(s) with a fixture from the library.

Set Node Order... Change the node order of the selected fixture. 

Unassociate Break the link between selected fixtures and power supplies. 

Set Layer Move selected fixtures to a different layer. 
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Power Supply Menu (Mac and Windows)

View Menu (Mac and Windows)

Select... To...

Add Supply... Add a virtual power supply to the power supply list.

Remove Selected Supplies Delete selected power supplies from the power supply list. 

Refresh List Update the power supply list. 

Discover Nodes Query the selected power supply for connected nodes.

Get Info... View and edit information for the selected power supply.

Discover Nodes for All 
Power Supplies Query all power supplies for connected nodes. 

Select... To...

Zoom In Display a smaller section of the map.

Zoom Out Display a larger section of the map.

Zoom 100% Jump to 100% zoom level. 

Layers Select layers to hide / display. 

Layers / Manage Layers... Add, delete, and rename layers. 

Resolution Guides Place a box representing video frame on the grid. 

Toolbar Select toolbar options. 

Show Power Supplies Toggle display of the power supply list.

Show Fixture Boundaries Toggle display of fixture boundary lines.

Show Grid Toggle grid lines.  

Show Background Image Toggle display of background image (if loaded). 

Send Background Image to 
Lights Display the background image on the lighting fixtures.   

Show Node Order Toggle display of the fixture node order.

Show Port Indices Toggle display of port numbers in virtual fixtures. 

Script Interpreter... Open the Script Interpreter window. Note: The Script Interpreter is  
for advanced users. Click Docs to view functions.  
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VSE Menu (Mac and Windows)

Help Menu (Mac and Windows)

Select... To...

Status: (message only) See whether VSE Pro is connected or disconnected to VMT. 

Pause VSE Toggle VSE Pro output. (Output must be paused to access power 
supplies.)

Transfer Map to VSE Send a map to the VSE Pro. 

Fetch Map from VSE Retrieve a map from VSE Pro. 

Capture Image from VSE Take a snapshot of the video to use as the background image.

VSE Website Open the VSE Pro interface in a web browser. 

Select... To...

About VMT (PC only) Display software version information.

VMT Website Visit the VMT website (requires an Internet connection). 
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Chapter 6

Placing Fixtures on the Map

Overview
Every fixture in an LED lighting system must be represented on the video map by a matching 
virtual fixture. The section of the video frame displayed by a real fixture is determined by the 
grid position of its virtual fixture.   

To place a virtual fixture on the map, you add it from the fixture library or create a new one. 
After that, there are many ways to work with it. This section describes the following: 

• Create and save new fixtures

• Copy, duplicate, and clone fixtures

• Remove and replace fixtures

• Move, rotate, and lock fixtures

• Check and modify node order

• Move, add, delete, distribute, and mask nodes

• Group and ungroup fixtures

• Use groups of fixtures as templates

• Work with layers and overlapped fixtures
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About Node Spacing

When there are too few lighting fixtures to display the entire video frame at 1:1 resolution, 
which is the case with most lighting systems, you must choose between showing a smaller 
portion of the frame at 1:1 resolution or displaying the full frame at lower resolution. 

Often, you decrease resolution by sampling the video image to fit the display at the video source.

When using full resolution video, you can achieve lower resolution by spreading the virtual 
nodes evenly over the video frame. There are two ways to do this. 

• You can use the Distribute Nodes... command in the Edit menu to space nodes evenly to 
fit the video frame. See Distributing Nodes on page 30.

• You can calculate the node spacing required to distribute the nodes evenly over the video 
frame and enter this spacing in the Space Between Nodes fields in the New Fixture 
dialog when creating fixtures. 

The VSE Pro can also adjust resolution; refer to Chapter 7 in the Video System Manager Pro User 
Guide for details. 

Creating and Saving Virtual Fixtures

Creating a New Fixture
You can create and save new fixtures as needed. 

To create a new fixture: 

1. Click Add Fixture on the toolbar or select New Fixture from the Fixture menu. The 
New Fixture dialog opens. 

2. Enter the number of nodes that the real fixture measures across and down in the Node 
Width and Node Height fields.

3. Enter the horizontal and vertical node spacing, if any, in the Space Between Nodes fields.  

4. Click OK. The new fixture is created and placed on the map.
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Saving Fixtures

You can save your fixtures in the fixture library. You are not limited to saving single fixtures, 
multiple fixtures and groups can be saved as well. 

To save a fixture in the library:   

1. Select the fixture or fixtures to save.  

2. Select Save to Library... from the Fixture menu or context menu. 

3. Enter a name in the Save As dialog and click OK. 

Adding Library Fixtures to the Map
The fixture library contains common Philips lighting fixtures and any fixtures that you create 
and save. 

To add a fixture from the library to the map:  

1. Click the  button on the toolbar (to the right of Add Fixture) or select Add Fixture 
from the Fixture menu.

2. Select the desired fixture from the library list. The fixture is added to the map. 

Three Ways to Copy Fixtures
After placing a fixture on the map, there are three ways to copy it.

Copying and Pasting   
To copy using Copy / Paste: 

1. Select a fixture or group.

2. Create a copy by selecting Copy from the Edit menu. 

3. Paste as many copies as desired Paste from the Edit menu. 

Duplicating Fixtures 
To copy using Duplicate:  

1. Select a fixture or group.

2. Select Duplicate from the Edit menu.   

Cloning Fixtures
Cloning allows you to copy fixtures too, but has an advantage over copying and duplicating that  
saves time when associating fixtures. See Using Groups as Templates on page 30. 

To copy using Clone: 

1. Select the Clone tool from the toolbar or menu.  

2. Place the cursor on the fixture or group to clone, preferably one that is not surrounded by 
other fixtures.

3. If possible, drag the mouse towards an unoccupied area of the map. Additional clones are 
created as you drag. 
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Replacing and Removing Fixtures

Replacing Fixtures
The Replace with command allows you to replace fixtures on the map with a fixture from 
the library. 

To replace one or more fixtures: 

1. Select the fixture to replace.

2. Select Replace with from the Fixture or context menu. 

3. Select the fixture to insert from the library list.   

Removing Fixtures 
You can delete fixtures from the map by selecting them and then pressing the delete key or 
selecting Delete from the Edit menu. 

Moving and Rotating Fixtures
After adding a virtual fixture to the map, you rotate and move it as required to position it over 
the grid cells that represent the video pixels to be displayed by the real fixture. 

Rotating Fixtures
To rotate or flip a fixture: 

1. Select the fixture to rotate or flip.

2. Select Transform from the Edit menu. 

3. Select the type and degree of transformation from the context menu. 

Moving Fixtures
To move one or more fixtures:  

1. Select the Move tool.

2. Select the fixture or fixtures to move.

3. Drag and drop the fixture(s) to the desired location with the mouse, or move with the 
arrow keys. 

Tip: Pressing and holding the shift key while pressing an arrow key moves objects 10 spaces.  

Locking Fixtures in Place
You can prevent fixtures from moving by locking them. Locking does not prevent other 
operations.   

To lock fixtures in place:

1. Select the fixture(s) to lock.

2. Select Lock Selected Fixtures from the Edit menu. 

To unlock locked fixtures, use Unlock Selected Fixtures.  
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Working with Nodes
You can modify fixtures at the node level in several ways: nodes can be moved, re-ordered, 
added, deleted, distributed, and masked. 

Modifying Node Order
Virtual fixtures are placed on the map with a default node order. Examples of node ordering 
schemes are shown below. 

For correct display, the node order of the virtual fixture must match the node order of the 
real fixture. You can modify the node order of most fixtures using the Set Node Order dialog 
as follows: 

1. Select the fixture to modify. 

2. Select Set Node Order... from the Fixture or context menu. The Set Node Order 
dialog opens.

3. In the top row, click the icon with the green dot in the position of node 1.

4. In the bottom row, click the icon with the matching node order.

Verifying Node Order
When working online, you can verify correct node order as follows: 

1. Associate the fixture with its power supply port. 

2. Select the Sel. Node tool. 
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3. Drag the mouse diagonally over the virtual fixture. If the node order is correct, the nodes on 
the real fixture light up to follow the mouse. 

Creating Irregular Fixtures (Adding and Deleting Nodes) 

Irregular fixtures can be created using the Add Nodes and Delete Nodes tools. For example, 
to create the fixture shown above, you could create a 5 x 5 node fixture and add 3 nodes to 
each side, or create a 7 x 7 node fixture and delete 3 nodes from each corner.

To add nodes:  

1. Select the fixture to modify.   

2. Select Add Nodes from the toolbar or Tool menu.  

3. Click in a grid cell to add a single node, or drag the mouse to add multiple nodes. 

4. When all nodes have been added, select a different tool before clicking again in the 
map window. 

The procedure for deleting nodes is similar. 

Tip: With some irregular fixtures, it may be necessary to modify the node order manually: use 
the Move Nodes tool to reorder the nodes. 

Masking Nodes
Nodes can be masked (set to display black output) to prevent them from displaying video. 
Masked nodes are displayed in red. 

To mask nodes: 

1. Select Sel. Nodes tool. 

2. Select the nodes to mask. 

3. Select Mask Selected Nodes from the Edit menu. 

To unmask nodes, use Unmask Selected Nodes. 
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Distributing Nodes
The Distribute Nodes command spreads selected nodes evenly over a designated rectangle. It 
provides an easy way to distribute nodes to fit a video frame. Perform this step after placing all 
fixtures on the map. 

To distribute nodes:

1. Select the fixtures to distribute. (To select all fixtures, use Select All in the Edit menu.)

2. Select Distribute Nodes... from the Edit menu. The Distribute Nodes dialog opens.  

3. Enter the Y-value of the rectangle’s top-left corner in the Top field; enter the X-value in the 
Left field.

4. Enter the rectangle’s width and height and click OK. 

Tip: Use a resolution guide or a background image with the desired frame size and the 
coordinates displayed on the status line to find the top-left corner. 

Grouping and Ungrouping Fixtures
Multiple fixtures can be merged into groups, which makes it easier to copy and move several 
fixtures at once. 

To create a group, select the fixtures and then select Group from the Edit menu. To ungroup 
fixtures, select Ungroup from the Edit menu.  

Using Groups as Templates
When a lighting system has many identical fixtures that are laid out and connected in a repeating 
pattern, you can save time by grouping and cloning fixtures associated with a power supply. 

To create a group for cloning:

1. Place virtual fixtures on the map to match the real fixtures connected to a power supply.

2. Associate the fixtures with a real or placeholder supply as described in later chapters.  

3. Group the fixtures. 

To clone and associate a group: 

1. Select the Clone tool. 
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2. Create a clone of the group and position it on the map.

3. Select the group’s power supply and select the Associate tool. 

4. Click anywhere in the group to associate all fixtures.

Working with Overlapped Fixtures
Two or more real fixtures can be mapped to display the same image by placing their virtual 
fixtures on the same grid cells. 

When fixtures overlap, clicking anywhere they overlap selects the top fixture. To select a lower 
fixture, you can either 

–Use [Alt]-click to cycle through the stack of fixtures; or 

–Select Move to Back from the Edit menu or context menu to move the fixture to 
the bottom of the stack. 

You can select a lower fixture if any of its nodes are visible. Selecting Move to Front from the 
Edit or context menus moves the selected fixture to the top of the stack.   

Working with Layers 

About Layers
The fixture map can be divided into multiple layers that can be displayed or hidden as desired. 
This makes it easier to map fixtures that are stacked on top of each other. 

The Main layer is the layer on which fixtures are placed when added to the map. From there,  
they can be moved to another layer. When pasting, duplicating, and cloning fixtures, new fixtures 
remain on the same layer. 

Set Fixture Layer
To move fixtures and groups to a different layer: 

1. Select the fixtures to move. 

2. Select Set Layer from the Fixture menu. The layer selection list opens with the fixtures’ 
current layer indicated by a check mark (Mac) or box (PC). (Italic text indicates hidden layers.) 

3. Select the destination layer from the layer list.  

Mac version PC version
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Show / Hide Layers
Visible layers are indicated in the layer list by a box (PC) or check mark (Mac). 

To show or hide layers: 

1. Select Layers from the View menu. The layer selection list opens.  

2. Click a layer to toggle its display status.

To hide all layers but one: 

1. Press and hold the Alt key and then open the View menu. 

2. Select Layers from the View menu. The layer selection list opens. 

3. Click the one layer to display. The other layers disappear. 

Tip: Clicking Show All Layers with the Alt key depressed hides all layers. 

Layer Management
In the Manage Layers dialog, you can 

• Add and delete layers;

• Double-click layer labels to edit them;

• Double-click color fields to select a different color. 

To open the Manage Layers dialog, select Layers / Manage Layers... from the View menu. 
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Chapter 7

Working with Real Supplies

Overview

About Power / Data Supplies and Data Enablers
A power supply, also referred to as a Power / Data Supply or PDS, is a device that provides 
power to low-voltage LED fixtures and connects them to the lighting network. 

Some fixtures have built-in, onboard power processing capabilities. Fixtures with onboard power 
processing are paired with Data Enablers.

The map must link all fixtures to their power supplies or Data Enablers. The links are established 
by associating virtual fixtures with the power supply or Data Enabler ports to which the real 
fixtures are connected. 

This chapter describes how to work with real supplies and Data Enablers; placeholder supplies, 
which you use in place of real supplies when you cannot connect to the lighting network, are 
described in the next chapter. 

Terms Used to Describe Supplies 
When describing power supplies, the following terms are used. 

• A connected supply refers to a real supply that is connected to the lighting network and 
detected by VMT. It appears in regular text in the power supply list. 

• An unconnected supply refers to any supply, real or placeholder, that is associated with fixtures 
on the map, but is not detected by VMT because either the power supply or the VMT 
computer is not connected to the lighting network. An unconnected supply appears in italic 
text in the power supply list. 

• A placeholder supply refers to a supply created in VMT to stand in for a real supply. A 
placeholder supply is always unconnected and appears in the power supply list in italic text.  

• An associated supply refers to a real or placeholder supply that is associated with one or 
more fixtures. 

• An unassociated supply refers to a real or placeholder supply that has no fixtures associated.     
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Suggested Work Flow
The basic sequence for creating a map when connected to the lighting system network and 
working with real power supplies is as follows:  

1. Scroll through the list of power supplies and watch the fixtures light up until you find the 
supply for the fixtures in the top-left corner. (If nothing happens, you may need to pause the 
VSE Pro.)

2. Click a port selection button and determine the node dimensions of the connected fixture.  

3. Add a virtual fixture with the same node dimensions as the real fixture to the map. Rotate 
and move the virtual fixture as described in Chapter 6.

4. Associate the virtual fixture with its power supply port. See Associating Fixtures with a Real 
Supply on page 36.

5. Verify the fixture’s node order and change if necessary. See Modifying Node Order on page 28.

6. Add and associate fixtures for the remaining ports on the power supply. 

7. If the arrangement of fixtures connected to the power supply occurs repeatedly, create a 
group to use as a template. See Using Groups as Templates on page 30.

8. Repeat the process for each power supply. 

9. When all fixtures are on the map, adjust the node spacing, if necessary, to fit the video frame 
using the Distribute Nodes... command in the Edit menu. 

10. Save the completed map and transfer it to the VSE Pro. See Transfer Map to VSE Pro on 
page 42. 

Detecting Real Power Supplies
VMT automatically detects real power supplies and Data Enablers when connected to the 
lighting network and lists them in the power supply list. 

You can refresh the power supply list to reflect any changes to the installation by pressing  or 
selecting Refresh List from the Power Supply menu.  
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Power Supply Information

The Power Supply Info dialog, shown above, displays information for the selected supply. The  
power supply’s name and IP address can be edited. Changing the IP address of real supplies is not 
recommended if you are unfamiliar with Ethernet networks.     

Identifying Connected Fixtures

Determining Which Fixtures are Connected to a Power Supply
To determine which fixtures are connected to a power supply, select the supply from the power 
supply list. Connected fixtures light when their supply is selected. They light red if they are not 
associated, or yellow if they are.  

Determining Port Connections 
To determine how fixtures are connected to the ports of the selected power supply, click the 
port selection buttons. Connected fixtures light when a button is clicked. They light green if they 
are not associated, or yellow if they are.  

Note: the first click of a port selection button triggers a node discovery routine, which may 
cause the fixtures to blink or flicker (this is normal).

Associating Fixtures with a Real Supply
All virtual fixtures must be associated on the map with the power supply to which the real 
fixtures are connected.  

To associate fixtures with a real power supply: 

1. If the power supply list is hidden, select Show Power Supplies from the View menu. 

2. Select the Associate tool. 

3. Select a power supply from the list. 

4. Note the port number displayed by the Associate cursor . 

5. Determine which real fixture is connected to that port as described above. 

6. Click the virtual fixture that represents the real fixture.   

7. Repeat steps 4 through 6 for the remaining fixtures connected to the power supply. 
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Tips
• Use the arrow or number keys to change the Associate cursor’s port number.

• You can associate multiple fixtures to a port. Fixtures after the first one have a letter 
following the port index, for example “1b”. 

• To hide associated power supplies, use the Show Unassociated Only filter. 
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Chapter 8

Working with Placeholder Supplies

Overview

About Placeholder Power Supplies
You can use placeholder power supplies to stand in for real power supplies when they are not 
available, for example, when making a video map prior to system installation. You associate 
fixtures with placeholder power supplies just like real ones. Later, when connected to the 
lighting network, you combine the placeholder supplies with the real supplies. 

To work with placeholder power supplies effectively, you will need a lighting design plan that 
shows how the lighting fixtures are laid out and connected to the power supplies. For 
suggestions on creating a lighting design plan, refer to the VSM Pro Product Guide.

Specifically, you need the following information for each fixture:

• Power supply port connection (port number)

• Location within the video display

• Orientation and node order 

Ideally, you will also know the IP addresses of the real supplies, but you can give placeholder 
supplies temporary addresses that you can change later. 

Suggested Work Flow
The basic sequence for creating a map using placeholder supplies is as follows: 

1. Working from the lighting design plan, create placeholder supplies to stand in for the 
system’s real supplies. 

2. Select one of the placeholder supplies and add its virtual fixtures to the map. 

3. Move and adjust the virtual fixtures as described in Chapter 6. 

4. Associate the fixtures with the placeholder supply. 

5. If the arrangement of fixtures associated with the supply occurs repeatedly, create a group to 
use as a template and clone the group. See Using Groups as Templates on page 30.
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6. Repeat the process for each placeholder supply. 

7. When all fixtures are on the map, adjust the node spacing, if necessary, to fit the video frame 
using the Distribute Nodes... command in the Edit menu. 

8. Save the map. 

9. Later, when you have access to the lighting network, combine the placeholder and real 
supplies. See Combining Placeholder and Real Supplies on page 40.     

10. Transfer the map to the VSE Pro. See Transfer Map to VSE Pro on page 42. 

Creating Placeholder Supplies
To create placeholder supplies: 

1. If the power supply list is hidden, enable Show Power Supplies in the View menu. 

2. Click Add Supply... or select Add New Supplies from the Power Supply menu.  

3. In the Add Power Supplies dialog, enter the number of supplies to add. 

4. Enter a name to identify the supplies. If you want a running number appended to the name 
when adding multiple supplies, enable the Add index option.

5. Enter the IP address. If adding multiple supplies, enter the IP address to start with; the 
IP address of subsequent power supplies increments automatically. 

6. Enter the number of output ports on the supply. 

7. Click OK. 

Tips
• Enter the IP address of the matching real supply whenever possible. If you do not know the 

IP address, use the one suggested as a temporary IP address, and give the placeholder power 
supply a descriptive name that will help you match it to the real supply. 

• A placeholder supply’s name, IP address, and number of ports can be modified in the Power 
Supply Info dialog. Select the supply and click the Get Info... button to open the dialog. 
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Associating Fixtures with a Placeholder Supply
All fixtures must be associated with a supply port. You can associate multiple fixtures to a port. 
Fixtures after the first one have a letter following the port index, for example “1b”. 

To associate fixtures with a placeholder power supply: 

1. If the power supply list is hidden, select Show Power Supplies from the View menu. 

2. Select the Associate tool. 

3. Select a power supply from the list and note the number displayed by the cursor . You 
can use the arrow or number keys to change the cursor’s port number.

4. Click the placeholder fixture to associate with the port designated by the cursor number. 

5. Repeat step 4 for the remaining fixtures connected to the power supply. 

Combining Placeholder and Real Supplies

Overview
You merge the placeholder supplies with real ones when you can connect the VMT computer to 
the lighting network. 

The process for combining supplies depends on whether the placeholder supplies were given a 
real or temporary IP address when they were created. Each case is described below. 

Combining Placeholder Supplies that Have Real IP Addresses
When placeholder supplies have IP addresses that match the IP addresses of real supplies on the 
lighting network, VMT combines the placeholder and real supplies when it connects to the 
network. 

If the names of placeholder and real supplies differ, you must choose which name to use. The 
Power Supply Name Conflict dialog gives you three options: 

• Leave both names as they are: The supplies are combined but their names remain 
unchanged. 

• Keep power supply name (overwrite map name): The combined supply is identified by 
the real supply’s name. 

• Keep map name (overwrite power supply name): The combined supply is identified by 
the placeholder supply’s name. 

Combining Placeholder Supplies that Have Temporary IP Addresses
To combine a placeholder supply with a real supply when the IP addresses do not match: 

1. Locate the real supply to combine with and note its IP address. (The real supply must not be 
associated with any fixtures.) 

2. Click the placeholder supply and then click Get Info. 

3. Enter the real IP address and click OK. Click YES at the verification prompt.  
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Chapter 9

Working with the VSE Pro

Overview
VMT provides access to the VSE Pro so you can perform the following tasks when connected to 
the lighting network: 

• View connection status

• Transfer a map to the VSE Pro

• Get a map from the VSE Pro

• Pause video output, which is required to access power supplies

• Capture a video snapshot to use as the map background

• Preview the video display

• Open the VSE Pro user interface to perform additional tasks

View Connection Status
The status of the connection to the VSE Pro is displayed on the top line of the VSE menu. 

If you connected the computer to the lighting network after opening VMT and the status 
message is “Not Connected”, close and restart the application. If that doesn’t work, change your 
network preferences, as described in Chapter 3.

Transfer Map to VSE Pro
The map of the lighting system must be transferred to the VSE Pro. 

To transfer a map to the VSE Pro: 

1. Open the map file to transfer.

2. Open the VSE menu and confirm that the VSE Pro is connected. 

3. Click Transfer Map to VSE. 



Running H/F 1

43  VMT User Guide

Get Map from VSE Pro
The VSE Pro’s map can be transferred to VMT for modification, backup, etc. 

To fetch a map from the VSE Pro: 

1. Save your work if you have a map open. 

2. Open the VSE menu and confirm that the VSE Pro is connected. 

3. Select Fetch Map from VSE. The map opens in the VMT map window. 

Pause Video Output
VMT cannot control lighting fixtures while there is output from the VSE Pro. To toggle output on 
or off, select Pause VSE from the VSE menu. Output is paused by default when VMT starts up. 

Capture Image
You can grab a video snapshot from the VSE Pro to use as the background in the map window.

To grab a snapshot, select Capture Image from VSE from the VSE menu.  

Preview the Video Display
You can preview the video display and test the map by sending a background image to the lights. 

To send a background image to the lights, capture an image or load one as described under 
Background Image on page 14, and then select Send Background Image to Lights from the 
View menu. 

Open VSE Pro Interface
The VSE Pro has a Web-style interface that allows you to perform additional tasks using your 
web browser; see the Video System Manager Pro User Guide for details. 

To open the VSE Pro browser interface, select VSE Website from the VSE menu.  
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Chapter 10

Advanced Functions

Combining Maps
You may find it easier at times to create partial maps and combine them later into a single map. 
This can be done using the Append Map command in the File menu. 

To combine two or more maps:

1. Open the map file that you want to add to, or start with a new map. 

2. Select  Append Map... from the File menu. 

3. Select the map file that you want to combine with the open map and click Open. 

4. Repeat steps 2 and 3 for each additional map to append. 

5. Save the combined map. Use the Save Map As... command if you do not want to lose the 
partial map that you started with. 

Tips
• The combined map will have one set of layers for each partial map. You may want to use 

descriptive layer names and delete unused layers before appending. 

• The Undo command will NOT roll back an append operation. Save your work as you go so 
you can discard changes if you accidentally append the wrong map. 
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Exporting Maps 
You can export a map to a CSV (comma-separated values) file suitable for use in spreadsheet 
applications. For every node on the map, the exported file contains an IP address, port number, 
DMX address, grid coordinates, mask state, and KiNET™ version. The KiNET version is for 
applications that need to differentiate between types of power supplies. 

Manual Network Configuration
If the computer’s network adapter fails to connect automatically to the lighting network, the 
network settings may need to be configured manually. 

Be sure to record any settings that you change. If your computer is connected to a local area 
network, the original settings will need to be restored when reconnecting to that network. 
Please consult with your network administrator if you need to make any changes to firewall 
settings.

Windows® 
To set the IP address manually:

1. Open Network Connections: click Start, click Control Panel, and then double-click 
Network Connections. 

2. Right-click the local area connection for the lighting network and select Properties from 
the context menu.

3. On the General tab, select Internet Protocol (TCP/IP) from the list of items used. 
Note: click the label, not in the check box. 

4. Click Properties. Select Use the following IP address. Record the settings in each field 
for later use. 

5. In the IP address field, enter 10.1.3.21; in the Subnet mask field, enter 255.0.0.0. 

6. Ignore the Default gateway field. Click OK. 

Close the Local Area Connection Properties dialog. 
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Mac OS X Network Configuration
1. Select System Preferences from the Apple menu. Click Network. 

2. Select Edit Locations from the Location list and click Add (+). 

3. Enter a name for the network and click Done.

4. Click Ethernet in the device list. 

5. Select Manually from the Configure list. 

6. In the IP address field, enter 10.1.3.21; in the Subnet mask field, enter 255.0.0.0. 

7. Click Apply. 
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Chapter 11

Tutorials

Tutorial 1: Building a Virtual Video Map 

Overview
This tutorial covers building a virtual video map for an installation using two power supplies and 
two iColor® Tile FX fixtures. A virtual video map can be created offsite, prior to an installation, 
without connecting to any lighting system components. 

• Each iColor Tile FX module in this example has 6 rows and 6 columns of nodes for a total of 
36 nodes per tile. 

• The power supplies for the virtual video map both have two output ports. One port on each 
power supply will connect to a fixture.

Step One: Adding Placeholder Power Supplies
When you launch VMT, the main window appears showing an empty map grid and a list of power 
supplies. Select Add Supply... to start creating power supplies. The Add Power Supplies dialog 
lets you specify how many supplies to create and what their settings are. For this example,  
create two placeholder supplies, each with two ports. When you click OK, you should see two 
supplies appear in the list.

Step Two: Creating the First Fixture
To start creating the tiles, create a fixture with 36 nodes:

Click Add Fixture at the top of the main window. A dialog will appear asking for the 
dimensions of your fixture. Enter 6 for the Node Width and 6 for the Node Height (leave 
the Space Between Nodes as 0.) Click OK and the first fixture will appear on the map, in 
the top left corner.
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Step Three: Creating Additional Fixtures

There are several ways to add more fixtures to the map. This step covers the clone tool. The 
clone tool offers a quick way to click and drag copies of fixtures on your map: 

Select the clone tool, then click on the fixture created in the previous step while holding 
the mouse button. Drag horizontally across the map to create one copy of the fixture, 
then release the mouse button. 

Step Four: Associating Fixtures to Power Supplies
The next step is to associate the fixtures to ports on the power supplies: 

Select the first power supply you created by clicking on its name in the power supply list. The 
name is probably Power Supply 1.

Select the associate tool — the cursor should change to a “1”, indicating that you're going 
to associate fixtures to output port 1 of the selected power supply: 

Click on the first fixture. It will turn yellow, indicating that it is associated, and a badge will 
appear in its top left corner showing its port number. 

Select the second power supply, and follow the same steps. 

You’ve associated each fixture a port on a power supply. You can save your map.
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Tutorial 2: Interactively Mapping a Lighting Installation 
This tutorial covers how to map a live installation while connected to the lighting network. 

For simplicity, we will assume for that you have connected to a network that contains the same 
installation described in the first tutorial: two power supplies, each with two output ports. The 
first output port on each supply is connected to a 36-node Tile fixture.

Step One: Examining Power Supplies
When you launch VMT while connected to a lighting network, the main window shows an empty 
map grid and a list of any power supplies or data enablers that are connected to the network. 
Note that on a live network, you will see both power supplies listed by name and IP address. If 
you click on a power supply in the list, all of the fixtures attached to that supply will light up red.

Below the list of supplies is a group of buttons that connect directly to each port of the selected 
power supply. If you click on one of the port buttons, the nodes of any connected fixture will 
light up green. 

There is also text below the port buttons indicating how many nodes were detected for a 
particular port. For the Tile that is connected to the selected port, the number is 36.

Using this interactive method of discovery, you can identify which nodes on which fixtures are 
connected to the ports of your power supplies. This information will help you create a map.

Step Two: Creating A Fixture
In this example, each port is connected to a 6 x 6 Tile module of nodes:

Create a fixture by clicking Add Fixture at the top of the main window, then enter 
dimensions of 6x6.

Step Three: Associating
Before creating the other fixture, associate the newly created fixture to a a port:

Select the power supply that you want to connect to the fixture you just created.

Select the associate tool — the cursor should change to a “1”, indicating that you're 
going to associate fixtures to the first output of the selected power supply. 

Click on the fixture — it will turn yellow to indicate that it's associated, and a badge will 
appear in its top left corner showing its port number. 

Step Four: Examining Node Order
While we know that we’ve connected a fixture with the right shape (6x6) and number of nodes 
(36), we don’t know if the node order is correct. Because every node on the map will be 
matched exactly with a particular pixel of the video source, it is essential that the node ordering 
is correct.

Switch to the select nodes tool. Now you can click-and-drag across your fixture to select 
specific nodes. This allows you to compare the node indexes on the map with the 
locations of the nodes on the connected tile. For example, if you select the top-left node 
on your map (#1), the top-left node on your tile should light up.
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If the node order is set correctly, each node’s position on the map should correspond exactly 
with the node position on the tile.

Step Five: Changing Node Order
If the nodes are not in the correct order there are a number of ways to make corrections. For 
this example, let’s say your tile has been installed upside-down (a common occurrence) and the 
nodes start in the bottom-right corner, proceeding up the tile, instead of vice-versa.

The simplest solution is to use the select tool and select the fixture on the map and then select 
set node order… from the Fixture menu. The node layout for most fixtures follows a predictable 
pattern, and this dialog gives you the ability to match the fixture to any common pattern. For 
example, to start in the bottom-right corner and proceed up, the dialog should look like this:

A second technique is to use the Transform menu options to rotate and flip the fixture until 
the nodes are arranged correctly.

The third technique, which is often useful with various kinds string fixtures, is to use the move 
nodes tool to manually arrange the nodes to match your installation.
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Step Six: Adding the Second Tile

Use the clone tool to create your second Tile:

Select the first tile, then select Clone from the menu bar. 

Now select the second power supply from the power supply list so that you can associate it with 
the the fixture.

Click on the fixture to associate it.



Tutorials

53  VMT User Guide



VMT User Guide   54

A
about VMT 3
add fixture 21
add index 39
add nodes 21, 29
add power supplies dialog 39
add supply... 22
append map... 19, 44
associate 21, 30, 35, 36
automatically check for updates 11

B
background image 14, 19, 22, 23, 30, 42, 43

C
capture image from VSE Pro 23
check now 11
clone 21, 26, 30
color preferences 11
copy 20, 26
CSV file 45
cut 20

D
delete 20
delete nodes 21, 29
deselect all 20
discover nodes 22
discover nodes for all power supplies 22
distribute nodes 20, 25, 30, 35, 39
DMX address 5, 45
duplicate 20, 26

E
exit 19
export Map to CSV... 19

F
fetch map from VSE Pro 23
firewall 9
fixtures

associating 6, 21, 34, 36, 38, 40
irregular 29
library 21, 24, 26, 27

new 21, 24, 25, 31
saving 26
overlapped 31
replace 21, 27
status 15
unassociate 21
virtual 14, 24, 25

G
get info... 22
grid size 14
group 20, 30
groups

as templates 30
breaking 30
cloning 26, 30
duplicating 26
saving 26

I
IP address

combining 40
edit 35, 45
filter by 15, 10
network preference 10
placeholder supply 39, 40
setting 9, 45, 15
temporary 38, 39, 40

K
keyboard shortcuts 13
KiNET version 45

L
layers 21, 31

change 31
display 22, 32
hide 32
in appended maps 44
main 31, 32

library 26
load background image... 19
lock selected fixtures 20

Index



Index

55 VMT User Guide

M
mac 8
manage layers dialog 32
manage layers... 22
map window 14, 15, 19
maps

combining 44
exporting 45
test 43, 7, 23, 42

mask selected nodes 29
move 21, 27
move to back 20, 31
move to front 20, 31

N
network

configuration 9, 45
lighting system 9, 10
preference 10

new fixture... 21
new map 19
nodes

add 21, 29
delete 21, 29, 14, 25, 35, 20, 25, 30, 35,

39
mask selected 20
masked 14, 20, 29
move nodes 21, 29
order 15, 21, 28, 29
select 21, 25
unmask 20
verify order 28

O
open map... 19

P
pan 21
paste 20, 26
PDS 34
port connections 36
port number, change 36
port selection buttons 16, 35, 36

power supplies
about 34
combining 40
detecting 35

power supply 34
associating fixtures 36
connected fixtures 36, 23
discover nodes 22
Info dialog 35, 39
KiNET version 45
list 15, 22
name conflict dialog 40
port numbers 15
refresh list 35, 22
template 30, 34
virtual 34, 38

associate fixtures 40
creating 39

preferences... 20

R
redo 20
refresh list 22, 35
remove selected supplies 22
replace with 21, 27
resolution guides 22, 30

S
save map 19
save map As... 19
save to library... 21
script interpreter... 22
sel. nodes 21
select 21
select all 20
select next node 20
select previous node 20
send background image to lights 22
set layer 21, 31
set node order... 21
show

all layers 32
background image 22
fixture boundaries 22



VMT User Guide   56

grid 22
node order 22
port indices 22, 36, 39, 40

show unassociated only 36
shows 7
space between nodes 25
status bar 16

T
test patterns 14
title bar 13
toolbar 13, 22
transfer map to VSE Pro 23
transform 20, 27

U
unassociate 21
undo 20
ungroup 20
unlock selected fixtures 20
unmask selected nodes 20, 29
update options 11

V
video resolution 25
VMT website 23
VSE Pro 7, 8, 9

get map from 43
open interface 43
pause 23, 43
status 23, 42
transfer map to 7, 23, 42

VSE Pro website 23

W
Windows 8

Z
zoom level 13
zoom tools 14, 21, 22


